GNU C Loader Root Privilege Security Exploit

Tuesday Oct 19th 2010 by Developer.com Staff
Share:

The GNU C Library loader can be manipulated to give a hacker root access to Linux servers and workstations.

Linux distributions are working to plug a severe security hole.

There's a vulnerability in the library loader of the GNU C library that can be exploited to gain root access.

The hole was discovered by Tavis Ormandy.

The H reported, "Using various tricks involving hard links, redirected file descriptors and environment variables, Ormandy managed to exploit the vulnerability and open a shell at root privilege level."

Share:
Home
Mobile Site | Full Site
Copyright 2017 © QuinStreet Inc. All Rights Reserved