Improved Plugin Support in Rails 3

Thursday Feb 11th 2010 by Developer.com Staff
Share:

Open source Ruby on Rails 3 plugin support gets a major overhaul.

Plugin support in Rails 3 is getting a major overhaul.

Developers for the popular open source Ruby framework are making big changes to the way plugin authors build and install their software.

To better deal with dependencies, Rails plugin developers should make their plugin a gem and have the user install it with a Gemfile.

"This will ensure that Bundler properly calculates the dependencies alongside any other dependencies the user’s app has," blogged wycats over at the Riding the Rails blog.

Also, to override ActionController, ActiveRecord or other Rails frameworks, require them first, then override.

This gives you the opportunity to hook in earlier to the initialization process, but it also means that you should explicitly require the dependencies you need," according to wycats post.

Rails 3 is a major release for the Ruby on Rails team.

Share:
Home
Mobile Site | Full Site
Copyright 2017 © QuinStreet Inc. All Rights Reserved